
 

                 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2009 – Forex Knight Rider EA, All Rights Reserved 
Version 1.0 – December 2009 

 



 

                 
 
 

Disclaimer and Risk Warnings 
 

Trading any financial market involves risk. The content of this e-book, its various 

associated websites and all related correspondence are neither a solicitation nor an 

offer to purchase or sell any financial instrument. 

 

Although every attempt has been made to assure accuracy, we do not give any express 

or implied warranty as to its accuracy. We do not accept any liability for error or 

omission. Examples are provided for illustrative and educational purposes only and 

should not be construed as investment advice or strategy. 

 

No representation is being made that any account or trader will or is likely to achieve 

profits or losses similar to those discussed in this e-book. Past performance is not 

indicative of future results. 

 

By purchasing the software, subscribing to our mailing list or using the website you will 

be deemed to have accepted these terms in full. 

 

The Broker-Nightmare's publishers, their representatives and associates do not and 

cannot give investment advice. 

 

We endeavour to insure that related websites are available 24 hours per day but we 

cannot be held liable if, for any reason, a site is unavailable. The information provided 

in this e-book is not intended for distribution to, or for use by, any person or entity in any 

jurisdiction or country where such distribution or use would be contrary to law or 

regulation or which would subject us to any registration requirement within such 

jurisdiction or country. 

 

Hypothetical performance results have many inherent limitations, some of which are 

mentioned below. No representation is being made that any account will or is likely to 

achieve profits or losses similar to those shown. In fact, there are frequently sharp 

differences between hypothetical performance results and actual results subsequently 

achieved by any particular trading program. 

 

 

One of the limitations of hypothetical performance results is that they are generally 

prepared with the benefit of hindsight. In addition, hypothetical trading does not involve 

financial risk and no hypothetical trading record can completely account for the impact 

of financial risk in actual trading. 

 

For example: the ability to withstand losses or to adhere to a particular trading program 

in spite of trading losses are material points which can also adversely affect trading 

results. There are numerous other factors related to the market in general and to the 

implementation of any specific trading program, which cannot be fully accounted for in 

the preparation of hypothetical performance results, all of which can adversely affect 

actual trading results. 

 

We reserve the right to change these terms and conditions without notice. You can 

check for updates to this disclaimer at any time without notification. 

The content of this e-book and all related websites and correspondence are copyright 

and may not be copied or reproduced. 



 

                 
 
 

Copyright Information 
 

Reproduction and or translation of any part of this work by any means electronic or 

mechanical including photocopying beyond that permitted by copyright law without the 

prior written permission of the publisher is unlawful and strictly prohibited. 
 

 

 

U.S. Government Required Disclaimer 
 
Commodity Futures Trading Commission Futures and Options trading have large 

potential rewards, but also large potential risk. You must be aware of the risks and be 

willing to accept them in order to invest in the FOREX, futures and options markets. The 

past performance of any trading system or methodology is not necessarily indicative of 

future results. 

 

 

 

 

 

 

 

 

 

 

 



 

                 
 
 

INTRODUCTION 
You've just purchased a unique and revolutionary automated trading robot 
The Knight Rider  
This trading robot (also known as an "Expert Advisor" or "EA" for short) will 
analyze and trade the Forex market for you, 100% automatically. It is quick 
and easy to install, as you'll see in a minute.  
 

Impressive features include: 

 100% automatic hands-free trading.  
 Watches the markets for you 24 hours each and every day.  
 Profitable trading without any hassles or emotional issues. 
 Eliminates destructive emotions of greed and fear.  
 Easy to use: quickly install and trade. 
 One Time Payment - Updates included - No monthly fee. 
 Built in unique and sophisticated Money Management. 
 Works on any account type, standard and mini accounts 
 Features Ground Breaking FKR „Scalping‟ Technology 
 Works On All Brokers (ECN Compatible) 
 96.67% ratio on automatic winning trades. (DAILY TRADING) 

 

 

Please Read The Instructions Carefully 

Before You Attempt To Operate The  

Knight Rider! 
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How to download & install 

MetaTrader 4 

 

The Knight Rider robot requires the “MetaTrader 4” trading platform 
which is freely available here: 

 

CLICK HERE TO DOWNLOAD METATRADER  

 

 

 

 

http://www.metaquotes.net/


 

                 
 
 

 
 

 
 
 
 
 

After the download is complete, please double click on the setup 

program (m4setup.exe) and you will get a screen like this: 

 

 
 

 
 

Choose your preferred language and click Next. 
 



 

                 
 
 

 
 

Click Next again to continue to User Agreement option. 

 

 

Tick the agreement box and continue with installation. 



 

                 
 
 

 

Click Next to continue with installation 

 

         Choose your preffered folder to install files. 

CLICK NEXT  

 



 

                 
 
 

                 

 

If you want to launch MetaTrader, tick the box and click Finish. 

 

 

 

 

 

 

 

 

 

 

 



 

                 
 
 

How to Open a Demo Account 

 
When MetaTrader 4 starts up for the first time, you will need to create a 
“demo” account, also called a “practice” account. 
 
 When you start MetaTrader for the first time, you'll see the following window. 
 
This is the window that enables you to open a free demo account. If you don't 
see this window when you open MetaTrader, choose from the File menu, 
Open An Account: 
 

 

Now enter your details. 

Check the tick box and click Next.  

If you are considering funding a live account with an amount between 
$500 and $10,000 then the “Deposit” setting for your demo account should 
ideally be 10x that amount. 
 
The reason is actually very simple: When you fund a live account with up to 
$10,000, the smallest order size permitted is 0.01 lots. Demo / practice 
accounts usually cannot open orders smaller than 0.1 lots i.e. 10x larger on 
many MetaTrader versions. 



 

                 
 
 

 
This can produce vastly skewed results when comparing demo trades with 
live trades so, to compensate, we simply increase the demo account deposit 
by a factor of 10 so, for example, if you plan to open a $5,000 live account 
then specify a $50,000 demo account - the larger demo account deposit 
therefore provides a means of comparing systems on a more level playing 
field. 
Click the "I agree to subscribe to your newsletters" box, which is 
mandatory if you'd like to proceed with opening the demo account. Then Click 
"Next". 
 
 

 

                      Click UWC-Demo.com and click Next 

 



 

                 
 
 

 

 

Remember to keep your login details in a safe place then click 

Finish. 

 

If you'd like to open a live real-money Forex account, it is important you open 

it with a reputable broker.  

The broker I trade with and highly recommend is FXCM: they offer superior 

execution, highly competitive spreads and a great customer service.  

 

 

 

 

 

 

 

 

 



 

                 
 
 

How to Install Knight Rider 

 

If you already have MetaTrader installed, than the first step is to ensure that 
you have the latest version.  
 
To do this, click “Help” in the main MetaTrader 4 menu, then click “About...” 
and a window similar to this: 
 

 

 

will appear showing the version and „build‟ details plus the date it was 
released. 
 

Note: The Knight Rider robot requires Build 225 or higher. 

Under normal circumstances, MetaTrader 4 will automatically check for 
newer builds each time you start the application and will immediately offer 
you the opportunity of updating your version. If you find that an earlier version 
is installed on your computer and you are not being offered the option of 
updating then please call your broker for assistance.   
 
 

 
 

 
 



 

                 
 
 

Assuming that everything is working correctly, if you open MetaTrader and 
you don't have the latest build, it will immediately display a window similar to 
this: 
 
 

 

 

 

 

 

 

 

  

Whenever you see a screen like this, click the “Start” button and MetaTrader 
4 will update itself to the latest release. The process does not take very long 
and will reduce the possibility of you encountering issues with robots that you 
may wish to use. 
 

Once complete, the following screen appears: 

 

 

 

 

 

 
Click the “Update and Restart” button to launch the updated version of 
MetaTrader 4. 
 
 
 
 
 



 

                 
 
 

 

   For Windows Vista users only! 
 

 

 

You might encounter problems with the automatic update facility of 
MetaTrader.  
 
Therefore, if you are asked to update MetaTrader: 
 

1. First close MetaTrader. 

2. Right-click on the MetaTrader icon on your desktop. 

3. Choose "Run As Administrator". 

4. Click "Allow" if asked to allow the running of the update program. 
 
 

 
 

 

 

 

 
 
 

Configuring MetaTrader 4 
 

If you have MetaTrader installed, it is recommended to go to the Options 
menu to check the settings there: 
 

From the Tools menu choose Options. 
 
 

 

 

 

 

 



 

                 
 
 

In the Options window that opens, click the Expert Advisors tab. 

You will see the following window.  

Make sure you check all the boxes that are checked in the screen shot below. 

  

 

 
 

 
 

 
 

 
 

 
 

 
 

 
 

Be sure to UNCHECK the boxes: 
 

 “Disable experts when the account has been changed” 
 “Disable experts when the profile has been changed” 
 “Ask manual confirmation” and  
 “Confirm DLL function calls”. 

 
Otherwise, the Knight Rider might not function correctly afterwards.  
 
Click the “OK” button to continue. 
 
The next stage is to install Knight Rider robot. 
  
Before doing so, MetaTrader 4 should be closed down by clicking the large 
“X” button in the top-right of the application window as shown: 
 

 

 



 

                 
 
 

How to Use the Knight Rider 

 
 

After you completed the purchase process, you received access to the Night 
Rider download page. 
 

1. From the popup menu right click and choose Save Target As… 
 

2. Choose a folder on your computer to download it to. For this example, 
I'll choose the My Documents folder. 

 
3. Navigate to the folder where you saved the Knight Rider file  

(in this case: C:\My Documents) 
 

4. Navigate to the folder where you saved the Knight Rider file  
(in this case: C:\My Documents) and Double-click the KnightRider.zip 
file. 

 

 
 

 
 



 

                 
 
 

Double-click the KnightRider_Setup.exe and the quick setup program will 
be launched: 
 
  
 
 
 
 
 
 

 
 

 
 
 
 
 

Click the Next button.  
 

You'll see the Find Your MetaTrader window: 
 

 
Now you need to locate the folder where you installed MetaTrader on your 

computer. 



 

                 
 
 

As standard, MetaTrader is installed under the Program Files folder, which is 
usually under the C: hard drive: 
 
C:\Program Files\MetaTrader Folder\ 
 
Unless you have deliberately chosen a different location, the Primary Path 
(C:\Program Files) will always remain constant. The only variation appears in 
the newer 64-bit (x64) versions of Windows where older, 32-bit applications 
such as MetaTrader 4 are installed into the “C:\Program Files (x32)” folder. 
 
However, the Application Folder varies for every broker providing 
MetaTrader 4. But don't worry - if you are not certain where your installation is 
located then there's a simple way to find out:  
 
Position your mouse cursor directly over (do not click!) the icon on your 
Windows Desktop that you use to start MetaTrader 4... 
 
click the Browse… button on the above screenshot circled in Blue .  

When the Browse For Folder window appears, double click on the correct 
folder name, in this case C: and then Program Files, and then: METATRADER 
4 

 
When the correct path appears in the 

top box click OK. 



 

                 
 
 

 
Click on the Next button and then on the Install button that appears: 

 

 
 

When the Finish button appears, click it to end the setup program. 



 

                 
 
 

If your MetaTrader is open, close it and then re-open.  
Check the Navigator pane on the left side of the MetaTrader 4 window 

 
 

 
 

Click the small [+] to the left of “Expert Advisors” to expand that section to 

display the available Expert Advisors (robots): 

If everything is correct then the list will contain the Knight Rider robot along 
with any other expert advisors that you have installed or were provided as 
part of the MetaTrader 4 system. 
 
Please note that the Knight Rider icon 
is gray whilst other icons in the list are 
colored: this is perfectly normal. 

 
A colored icon means that you have 
the “source code” for that particular 
robot i.e. the instructions that tell the 
expert how to trade. A grey icon 
means that you do not – almost all 
commercial experts will be gray.  
 
 
 
 
 
 



 

                 
 
 

SETTING UP FOR TRADING 

   
To begin trading, open a new chart of the EUR/USD currency pair by 

choosing New Chart from the File menu: 
 

 
 

then click EUR/USD (depending on your broker, you may find it in another 
sub-menu under the New Chart menu, such as Forex Crosses or a different 

name). 
 
Change the chart timeframe to 15-minutes (which is the Knight Riders natural 

preference), in the top toolbar click on the M15 button: 
 

 
 

In the navigator window, double-click the Forex_KnightRider_1.0 
 

 



 

                 
 
 

 

In the Knight Rider window that opens, click the Common tab to see these 
general options. Make sure your screen looks the same, especially the tick in 
the box "Allow live trading". 
 
It is very important that all Four of the settings circled in red match the image 
above or the expert advisor will not function correctly. 
 
Please pay special attention to the “Confirm DLL function calls” option 
which should be unchecked. 
 

 
 

Click the Inputs tab. You'll see all the different settings, which I'll now guide 
you exactly how to set:  
 

 



 

                 
 
 

 
Select the Start Lot you wish to trade with.  
 
The Risk Setting determines the initial trade size that the Knight Rider will 
enter the market. If you're not familiar with this concept, you may leave it on 
its default which is 20 or better still, change it to a smaller number such as 10 
which will lower the risk. 
 
Always use low Risk Setting! Remember leverage is a double-edge sword. It 
can increase both losses and profits.  
 
Example: if your starting account size is 1000 and your set Risk Setting to 5, 
it will open trades of 5,000 (i.e. 0.5 minilot). 
 
Make sure you set the correct Broker.GMT.Shift setting. This will enable the 
Knight Rider to identify the optimal times of day to trade. 
 
This is the value you need to insert in Broker.GMT.Shift according to your 
broker: 
 

Broker Broker.GMT 

value 

InterbankFX (IBFX) 0 

Alpari UK +2 

CMS UK +1 

FXCBS +3 

IamFX +1 

 
If your broker is not listed here, you should ask the broker what is the GMT 
shift, and input the value accordingly. 
 
The reason Broker.GMT.Shift is important, is because Knight Riders most 
active during night. Therefore it needs a way to know the exact time, even 
when there is Daylight Savings Time. Each broker displays different times, 
usually according to their respective time zones. 
 
 
 
 

Do not alter the last two settings, My.Robot.ID & 

My.Robot.Magic.Number! 



 

                 
 
 

Just click OK to apply the Knight Rider to the chart. 
 

                 Your chart should look like this: 
 

 
If you see a sad face You've probably forgotten to tick the "Allow live trading" 
box in the previous steps. 
 
In that case, in the navigator window double-click the Knight Rider again and 
click the Inputs tab.  
 
 

 
 

If you see an X next to the name… 
 

 
 
 
 
 
 
 

 

Make sure 
that at the top 
right corner of 
the chart, you 
see a smiling 
face like this. 

 
 

Press the large 

elongated toolbar 

button that says 

"Expert Advisors” 



 

                 
 
 

 

Important: Do not change the chart timeframe once the 

robot is attached. 
 

Your Forex Knight Rider Has Stealth Mode.  

True.Take.Profit and True.Stop.Loss are the actual parameter settings that 

the EA will trade with but, tell your broker that it is more in the 

Broker.Stop.Loss and Broker.Take.Profit so that your broker can‟t interfere 

if they wanted to try anything undesirable. 

These setting are set correctly but, you are free to tweak them if your 

comfortable doing it. 

 

Finally, add the indicator to the chart 

 

 



 

                 
 
 

Click the + on the Custom Indicators 

 

Find the KnightRider_Indicator and drag it into the chart. 

 

All settings are currently correct so you can click ok and your done. 



 

                 
 
 

You can change options here if you wish but, we do not advise it for those of 

you who don‟t know what you are doing. 

Check the following screenshots of correct settings. 

Inputs 

 

Colors 

 

 



 

                 
 
 

Visualization 

 

What you should see when it is completed 

 



 

                 
 
 

Troubleshooting  

 

Problem: My MetaTrader crashes when I operate the Knight Rider Expert 

Advisor. 

Solution: You‟re using an old version of MetaTrader. Updating to a new version is done 

automatically: when you open MetaTrader, and connect to any account (demo or live) it 

will open a “Live Update” window. You should allow the live update to run. 

 

Problem: I can't find the Knight Rider in MetaTrader  

Solution: The Knight Rider setup program automatically saves the Knight Rider files in 

the correct folders on your computer.  

However, if during the installation process you didn't choose the correct MetaTrader 

folder than you must run the setup program again. Please watch the installation video for 

complete instructions: 

 

Problem: I get a message "DLL not allowed" 

Solution: 

1. On your keyboard press CTRL+O or use the Tools -> Options menu to access the 
Options window. See screen shot below.  
 

2. Click the "Expert Advisors" tab. 
 

3. Make sure your Options windows looks exactly the same as this one, with several of 
the boxes are ticked, while others (the inner indented options) are NOT ticked: 
 



 

                 
 
 

 
 

Problem: The Knight Rider is running but no trades are being opened. 

Solution: It is normal not to have a trade in a certain day. The robot looks for a good 

opportunity to enter the market. If it doesn‟t spot a good enough opportunity to prey 

upon, it wouldn‟t jump in.  

Remember, the goal is to trade as profitably as possible, not as often as possible!   

Also, don‟t forget that the Forex market is closed on Saturday and Sunday. By the way, 

it's not necessary to turn off the Knight Rider during the weekend. 

However, if more than 3 days passed with no trade: 

 Verify that the robot is indeed working (smiley face at the top right corner of the 

chart). 

 If everything looks ok and still no trade, please contact our support team which 

will be happy to assist you: support@ForexKnightrider.com 

 

Problem: I try to run a back test of the EA and it doesn't work. 

 
Solution: Have you downloaded enough historical data? On your keyboard press the 

F2 key to access the data download window.  
 

mailto:support@ForexKnightrider.com


 

                 
 
 

Another possible problem arises when you forget to "Allow DLLs" in the MetaTrader 
options: 
 

4. On your keyboard press CTRL+O or use the Tools -> Options menu to access the 
Options window. See screen shot below.  
 

5. Click the "Expert Advisors" tab. 
 

6. Make sure your Options windows looks exactly the same as this one, with several of 
the boxes are ticked, while others (the inner indented options) are NOT ticked: 
 

 
 

 
Problem: What should I do if my computer rebooted or lost power? 

 
Solution: Just run MetaTrader again and make sure the Knight Rider is turned on (as 

explained in page 30). The Knight Rider will continue trading where it left off.  
 
If you have troubles with having the computer constantly open and connected to the 
internet, there is a low-cost solution using a VPS (Virtual Private Server). 
 
 

Problem: Where is the folder of MetaTrader experts? I can’t find it on my 

computer! 

 
Solution: As standard, MetaTrader is installed under the Program Files folder, which is 

usually under the C: hard drive: 
 



 

                 
 
 

C:\Program Files\MetaTrader Folder\ 
 
Primary Path   Application Folder 
 
Unless you have deliberately chosen a different location, the Primary Path 
 
(C:\Program Files) will always remain constant. The only variation appears in the newer 
64-bit (x64) versions of Windows where older, 32-bit applications such as MetaTrader 4 
are installed into the “C:\Program Files (x32)” folder. 
 
However, the Application Folder varies for every broker providing 
MetaTrader 4. But don't worry - if you are not certain where your installation is located 
then there's a simple way to find out:  
 
Position your mouse cursor directly over (do not click!) the icon on your Windows 
Desktop that you use to start MetaTrader 4... 
 
 

 

 

 

 

 



 

                 
 
 

Frequently Asked Questions (FAQ)  

 

What is a Forex robot (Expert Advisor) ? 

An Expert Advisor is computer software that's written in the MQ4 language, works in the 
Metatrader4 trading platform and trades for you automatically! 
 
What is Metatrader4 and where can I download it? 

 

Metatrader4 is a free trading platform. You can download it from your broker's website.  
 

 
What broker should I use? 

 

The Knight Rider works on the popular Metatrader 4 platform. You can use any broker 
you like that offers the MetaTrader platform (there are hundreds of them) its also 
compatible with ECN Brokers 
 

I have MAC OS. Can Metatrader4 work on MAC? 

 

Metatrader4 was originally created for Windows only. If you're a Mac user the best 

solution would be to have it installed on a VPS (Virtual Private Server) hosting service. 

 

Turning the robot on and off 

If for any reason you need to turn off the Knight Rider, you can do so by clicking the 

"Expert Advisors" button on the top toolbar: 

 

 

 

When this button has a white background, it means that Expert Advisors are active and 

able to open, close or modify trades. 

 

 

 



 

                 
 
 

Should I use a demo or real account? 

You should operate the Expert Advisor on a demo account only, until you're sure that it 

is compatible with your chosen broker, and you're sure about risking real money. And 

even then, never risk money that you can't afford to lose or don't want to lose. 

Always remember that leverage is a double-edge sword: it can increase both profits and 

losses. Using excessive leverage might cause you to lose your entire account. Use only 

low leverage to avoid getting into trouble. 

 

What settings should I use? 

The Knight Rider comes with default settings which are optimal for current market 

conditions. 

If you feel confident enough to tweak the default settings, use the Night Riders‟ Inputs 

tab as explained in setting up for trading section of the manual  

 

Currency Pairs to Use 

The Knight Rider currently works best with EUR/USD on the M15 (15-minutes) time 

frame.  

 
How much money do I need to start trading? 

 

You can start with relatively small account sizes such as $500 USD. However, 
remember that starting out with low trading capital may put you at disadvantage because 
you will only be able to trade the market in small trade sizes. It's best to start with capital 
of $1,000-5,000 USD or train on a Demo account till you are satisfied with the 
performance. 
 

Can I have several robots running on the same account? 

Yes you can. The Knight Rider uses a unique trade identifier called "MagicNumber". This 

is a unique identifier number attached to each trade it opens. The Knight Rider will only 

manage and close the trades that carry this unique identifier. If you have other robots 

running on the same account as the Knight Rider you need to make sure they also use a 

MagicNumber of their own. Otherwise they might interfere with the Knight Riders‟ 

trading. The Knight Rider itself is smart enough not to interfere with other robots' trades!  



 

                 
 
 

You're advised to also check the other robot's user guide, and to run everything on a 

demo account to monitor the behaviour of all robots together. 

 

Can I back test the robot on historical data? 

Sure. Backtest also allows you to try different parameters and see what worked best in 

the past. Past results are not indicative of future results (see disclaimer). 

When you're backtesting using the Strategy Tester built inside MetaTrader (View -> 

Strategy Tester) make sure you do the following: 

1. Choose from the Tools menu -> Options, click the Expert Advisors tab and make 

sure Allow DLL imports is ticked. Generally, your Options should look like this: 

 

 

 

2. To open the MetaTrader Strategy Tester, choose from the View menu -> Strategy 

Tester.  

3. Choose the Knight Rider expert advisor, the EUR/USD symbol and M15 period. You 

can also specify the dates to check. 

4. Click the Expert properties button, and click the Inputs tab: 

 



 

                 
 
 

5. In the Value box next to GMT, input your broker's GMT shift. If you don‟t know what 

is it, please contact your broker and ask the question: "what is your GMT shift?". 

6. Click OK to close this window, and click the Start button to start the backtest. 

 

How do I optimize the settings? 

  

If you're an advanced user, you can use optimization to search for different parameters 

than the default ones. The Knight Rider enables optimization of its parameters using the 

"Strategy Tester" window.  

See MetaTrader's help for further details. 

 

Does my computer need to be working all the time?  

Yes. For the Knight Riders‟ correct operation the following three conditions must be met: 

1. Your computer is constantly on. 

2. MetaTrader software is always working.  

3. You have a constant connection to the Internet.  

For example, when you have an open trade the Expert Advisor needs to constantly 

manage it (modify stop loss levels, close a trade, etc.). 

If you're not able to maintain constant connection to the internet, you should use a VPS 

(Virtual Private Server) service.  

 

Do I need to watch the Knight Rider when it is working? 

 

No, the robot frees you from the need to be glued to your screen 24/7 to look for trading 
opportunities. Everything is done automatically for you!  
You just need to be sure that MetaTrader stays open all the time and connected to the 

internet.  

 
What should I do if my computer rebooted or lost power? 

 

Just run MetaTrader again and make sure the Knight Rider is turned on (as explained in 
page 31). The Knight Rider will continue trading where it left off. 



 

                 
 
 

  
If you have troubles with having the computer constantly open and connected to the 
internet, there is a low-cost solution using a VPS (Virtual Private Server). 
 

The files are in zip format. Where can I get WinZip or other programs to 

unzip files? 

 

You can use the free WindowsXP/Vista zip service. You can also use free WinRAR to 
unzip files: http://www.rarlab.com/ 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.rarlab.com/
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